Support Has Moved!

Please post all new questions on the new support system

Before posting a discussion topic, be sure to check out our Forum Rules and Support Policy.

Get design feedback and approval with our newest WordPress plugin, ProjectHuddle. Check it out →

Latest Struck Version is 1.06

Latest GridStack Version is 1.1

Latest Edition Version is 1.6

Latest District Version is 1.2.6

Latest ExtraNews Version is 1.4.9

Latest Aware Version is 1.4

Latest BigFormat Version is 1.4

Latest Bookcase Version is 1.54

Latest Ellipsis Version is 1.5

remove <p> tags

ElaineStam's Avatar

ElaineStam

01 Nov, 2015 03:49 PM

Hey guys,

I'm not sure if this is a theme specific or Wordpress in general issue but I'm struggling with <p> tags inserting themselves into my posts and pages every time I save them. I can remove them over and over and they reappear every time and mess up my stylings.

Here is my website: http://87c.caf.myftpupload.com/

Any help or advice would be greatly appreciated,
Elaine

  1. Support Staff 1 Posted by Andre Gagnon on 02 Nov, 2015 12:43 AM

    Andre Gagnon's Avatar

    Hi Elaine,

    Which posts exactly? WordPress automatically adds paragraph tags to any lines without tags already present. This isn't a function of the theme, but a function of WordPress. What exactly are you trying to do?

    Andre

  2. 2 Posted by ElaineStam on 02 Nov, 2015 03:48 PM

    ElaineStam's Avatar

    That’s what I was thinking but I’ve never had this happen when using your theme before so I was confused.

    This page for example:
    http://87c.caf.myftpupload.com/clusters/ <http://87c.caf.myftpupload.com/clusters/>

    You can see my code is riddled with <p> tags and they mess up the formatting. I delete them all but then they reappear on save. It’s really annoying and difficult to deal with.

    <h4>Clusters bring people together to address broad or specific access to justice issues. If you have an idea for a cluster or would like to contribute to an existing one please <a href="http://87c.caf.myftpupload.com/contact/">get in touch</a>.</h4>
    <p></p>
    <p>[one_third]</p>
    <h2>Targeted Legal Services</h2>
    <p>How can lawyers and paralegals be encouraged to find innovative ways to meet the diverse needs of their clients?</p>
    <p>[button link="http://87c.caf.myftpupload.com/clusters/targeted-legal-services/" size="medium" ]More[/button]<br />
    [/one_third]</p>
    <p>[one_third]</p>
    <h2>Steps to Justice</h2>
    <p>This initiative creates practical information about common legal problems and related “next steps” in a digital format.</p>

  3. 3 Posted by Eric Schmidt on 03 Nov, 2015 02:57 PM

    Eric Schmidt's Avatar

    Hi,

    As Andre mentioned, this is a function of WordPress to automatically add paragraphs to content. You may want to switch over to Text view when editing and make sure those shortcodes are all on the same line, or there are no lines between them...

    [one_third]<h2>Targeted Legal Services</h2> [/one_third][one_third]Second Column here[/one_column]
    

    Eric

  4. 4 Posted by ElaineStam on 03 Nov, 2015 03:47 PM

    ElaineStam's Avatar

    Yeah I only use Text view. And i’ve tried putting everything inline. Guess I will try to figure out a way to disable this straight from Wordpress. Thanks anyway.

  5. Eric Schmidt closed this discussion on 04 Nov, 2015 03:10 PM.

  6. Eric Schmidt re-opened this discussion on 04 Nov, 2015 03:11 PM

  7. 5 Posted by Eric Schmidt on 04 Nov, 2015 03:11 PM

    Eric Schmidt's Avatar

    Hi,

    You can try a method like this...

    https://davidwalsh.name/disable-autop

    This may have unintended consequences so I'd test this out first before putting in place on a live site.

    Eric

  8. Eric Schmidt closed this discussion on 04 Nov, 2015 03:12 PM.

Comments are currently closed for this discussion. You can start a new one.

Keyboard shortcuts

Generic

? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac